Press "Enter" to skip to content

Category: Cisco 877

Cisco 877 New IOS v15 & DSL Firmware 4.0.18

Well well, it seems cisco has updated their Cisco 877 IOS with version 15!!

Latest IOSes on their site:
ADVANCED ENTERPRISE SERVICES
c870-adventerprisek9-mz.150-1.XA.bin
Release Date: 27/Oct/2009
Size: 23984.26 KB (24559880 bytes)
Minimum Memory: DRAM:128 MB Flash:28 MB

ADVANCED IP SERVICES
c870-advipservicesk9-mz.150-1.XA.bin
Release Date: 27/Oct/2009
Size: 23680.82 KB (24249152 bytes)
Minimum Memory: DRAM:128 MB Flash:28 MB

ADVANCED SECURITY
c870-advsecurityk9-mz.150-1.XA.bin
Release Date: 27/Oct/2009
Size: 20300.32 KB (20787520 bytes)
Minimum Memory: DRAM:128 MB Flash:24 MB

Just beware when you load these on, to watch out for the memory/flash requirements!

Also along with the new IOS versions, they have also released a recent DSL controller firmware, however no readme file yet for it!

Latest firmware:
adsl_alc_20190_4.0.018.bin
Description ADSL firmware version 4.0.18
Size 977.49 KB (1000952 bytes)

Will attempt to test the IOS/Firmware and see how they go, if anyone else has tested these please comment, and let us know how they are ūüôā

[ad#googleadd1]

14 Comments

Cisco 877 security hardening

I researched some more information how to tighten the 877 against security attacks, and usually on your dialer interface you might have this..

ip access-group 101 in

then a access list for incoming traffic via access-group 101 might look like this..

access-list 101 permit ip any any

However with having this set, means icmp, port attacks, or any other type of probing could be spoofed to gain access to your network. I have implemented the following access list filter to stop that from occuring, by blocking any internal LAN ranges from the wan side coming in via the dialer interface, and other type of bogus attacks.

access-list 101 deny   icmp any any echo                (blocks wan pings)
access-list 101 deny   tcp any any eq 139     (blocks port 139 netbios attacks used for ms fileshares)
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any  (blocks internal lan range)
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any (blocks internal lan range)
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any (blocks internal lan range)
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any  (blocks localhost spoofs)
access-list 101 deny   ip 50.0.0.0 0.255.255.255 any   (blocks unused 50.* address space which attackers may spoof)
access-list 101 deny   ip 100.0.0.0 0.255.255.255 any   (blocks unused 100.* address space which attackers may spoof)
access-list 101 deny   ip 101.0.0.0 0.255.255.255 any (blocks unused 101.* address space which attackers may spoof)
access-list 101 deny   ip host 255.255.255.255 any (blocks spoofing from this address)
access-list 101 deny   ip host 0.0.0.0 any (blocks spoofing from this address)
access-list 101 permit ip any any  (permits all other traffic)

Now once you have this in place, how do you know if you are actually getting hits from any of these rules, and if the 877 is dropping the packets if the acl matches?

There is one nice command to show that data…(need to be in priviliged mode)

cisco877#show access-lists
Extended IP access list 101
10 deny icmp any any echo (30 matches)  <30 hits on blocking wan ping from outside sources
20 deny tcp any any eq 139 log
30 deny ip 10.0.0.0 0.255.255.255 any
40 deny ip 172.16.0.0 0.15.255.255 any
50 deny ip 192.168.0.0 0.0.255.255 any
60 deny ip 127.0.0.0 0.255.255.255 any
70 deny ip 50.0.0.0 0.255.255.255 any log
80 deny ip 100.0.0.0 0.255.255.255 any log
90 deny ip 101.0.0.0 0.255.255.255 any log
100 deny ip host 255.255.255.255 any
110 deny ip host 0.0.0.0 any
120 permit ip any any (2954091 matches) <<lots of hits being allowed in from other sources not in access list (normal ip traffic flow)

Hopefully this is useful to someone wishing to implement a bit more security to their 877 setup ūüôā

Any questions post your comments.

[ad#googleadd1]

3 Comments

Setting up Cisco 877 with an external modem

Need to setup a 877 with an external ADSL modem in bridged mode? Maybe you have another modem which can sync/be more stable than the cisco and you wish to purely use the 877 as a router.

Following commands should help set it up..

Assign an ethernet interface to where it will use pppoe from, and assign it vlan2

interface FastEthernet3
description External DSL PPPoE
switchport access vlan 2

interface Vlan2
description External DSL PPPoE
no ip address
pppoe enable group global
pppoe-client dial-pool-number 2

setup a Dialer2 interface..

!
interface Dialer2
description connection to External DSL modem
ip address negotiated
ip access-group 101 in
no ip unreachables
ip nat outside
no ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1410
dialer pool 2
dialer idle-timeout 0
dialer-group 2
no cdp enable
ppp authentication chap callin
ppp chap hostname [email protected]
ppp chap password something

ip route 0.0.0.0 0.0.0.0 Dialer2

ip nat inside source list 102 interface Dialer2 overload

[ad#googleadd1]

5 Comments